WOOCS - Sélecteur de devise WooCommerce

La devise compte mal – double, zéro et autres…

Si vous ne savez pas pourquoi votre thème fonctionne avec WOOCS, essayez d'activer le thème par défaut et ne laissez que les plugins woocommerce et WOOCS activés. Même parfois, il suffit de changer le thème actuel par défaut pour comprendre que le thème wp est cassé. De tels cas ne peuvent pas être résolus ou vous pouvez les résoudre vous-même si vous comprenez comment fonctionne le woocommerce dans votre thème.


Exemple de cas sur la finition :

Merci d'avoir pris un coup d'oeil.
Le thème utilise une fonction pour ajouter un préfixe aux prix min/max. Lorsque je le supprime, le sélecteur de devises fonctionne à nouveau.

Pouvez-vous regarder la fonction et voir ce qui empêche le commutateur de devises de fonctionner ?

function custom_variation_prefixes($price, $product) { $price = ''; if (!$product->min_variation_price || $product->min_variation_price !== $product->max_variation_price) { $price .= ' ' . _x('Self-Study :', 'min_price', 'woocommerce') . ' '; $price .= woocommerce_price($product->get_price()); } if ($product->max_variation_price !== $product->min_variation_price) { $price .= ' ' . _x('Tutored :', 'max_price', 'woocommerce') . ' '; $price .= woocommerce_price($product->max_variation_price); } renvoie le prix $ ; }

Nous avons trouvé le problème !

Nous avons dû changer le max. chaîne de prix de $product->max_variation_price à $product->get_variation_regular_price( $min_or_max = 'max') donc cela fonctionne avec votre plugin

Merci beaucoup pour toute votre aide, très appréciée!


Donc, avant d'écrire que quelque chose fonctionne, vérifiez d'abord votre thème !

+

Seconde: désactivez tous vos plugins activés à l'exception de WooCommerce et WOOCS – il peut y avoir des plugins en conflit !

+

Assurez-vous de définir tous les codes de devise comme iciISO_4217 – Codes actifs

Si les problèmes persistent, activez-les dans les paramètres du plugin 'Stockage de devises' comme transitoire, redis ou memcached

+

Essayez le plugin dans les deux modes : 'Est-ce que plusieurs sont autorisés' -> comme Oui ou Non. Et si votre thème fonctionne dans l'un de ces modes mais que vous n'en avez pas besoin, vous pouvez écrire sur le support.

Tous les tests peuvent se faire sur sous-domaine de test (pour éviter des soucis avec les clients) avec clone du site réalisé par ce pluginhttps://wordpress.org/plugins/duplicator/